Slow loading of forms
Incident Report for ShForm
Resolved
This incident has been resolved.
Posted Sep 22, 2023 - 00:32 IST
Investigating
We are currently investigating this issue.
Posted Sep 21, 2023 - 19:12 IST
This incident affected: Forms, Back-End, Notifications, and Analytics.